Talk:On Screen Keyboard

From WebOS Internals
Jump to navigation Jump to search

Discuss bugs, implementation issues, installation issues and feature requests here:

Related to the last bullet in the issues list (text boxes getting moved behind keyboard because notifications don't resize the keyboard) - when a notification pops up, it covers the bottom row of keys on the keyboard (spacebar, shift, etc.), and they do not get re-drawn until you close and reopen the keyboard. --Swankgd 07:09, 3 September 2009 (UTC)

Can someone post instructions on how to get this working on the emulator? I'm trying to change the language of the keyboard for someone else and I don't have a Pre. Also I'm assuming that the section that starts around line 1252 of the add-onscreen-keyboard.patch file is where the outputted characters are set. If I want to change it to output  instead of q, do I change the Keycode, letter or list variables? --Qurgh 16:37, 15 September 2009 (UTC)

Keyboard doesn't work..

How do I get the keyboard to work. I've tried both the preload and webos? I am confused....

Use preware or webos quick install to install the mod. Open up the messaging app, focus on one of the text fields and double tap on the gesture area, This will bring up in the OnScreen Keyboard in all/(most) text fields. tap the gesture area once to make it go away.

Request for Development Progess

Can whomever is working on this patch post their progress with development? I'd like to contribute, but would like to know what the current status is and what work is being done, so I don't duplicate effort. Or is there a more formal process for submitting changes (CVS or some such)?

Thanks, Clebio 18:08, 24 April 2010 (UTC)

Keep getting error: kb_config.json does not exist on PalmPre

I've installed, uninstalled and reinstalled the virtual keyboard patch (Using the WebOS Quick Install) with the same result. Every time I double tap, I get an error message that file kb_config.json does not exist on PalmPre. I've looked for the virtual Keyboard folder both on my PC and on the PalmPrePlus (from ATT) and it's not there.

What am I doing wrong?

Many thanks for any help!

palm pre plus

will there be an update for activating this on the pre plus the double tap feature does not work for the plus